7编译安装

上BBS要用个工具,windows下边有cterm、fterm,linux上边有qterm

二进制包安装(推荐安装格局,不用安装注重包,特别有益):

理所必然想找个Fedora
11的rpm包,搜了半天,获得的是mandriva的rpm包,不是流行版,而且安装的依赖太多,装不上去。干脆下个源码包,自身装来个痛快。

1、下载安二进制包:

安装步骤

     wget

准备:

2、解压并创设软连接:

出于注重关系,要先装cmake和qt-devel,yum下就能够

     # tar zxvf percona-xtrabackup-2.4.7-Linux-x86_64.tar.gz

1.下载安装包,解压

      # mv percona-xtrabackup-2.4.7-Linux-x86_64 /usr/local/xtrabackup

tar xvf qterm-0.5.7.tar.bz2

      # ln -s /usr/local/xtrabackup/bin/* /usr/bin/

2.新建目录

3、查看版本:

mkdir build

      # xtrabackup –version

3.配置

      xtrabackup version 2.4.7 based on MySQL server 5.7.13 Linux
(x86_64) (revision id: 6f7a799)

cmake .. -DQT_QMAKE_EXECUTABLE=/usr/lib/qt4/bin/qmake
-DCMAKE_INSTALL_PREFIX=/usr/local/qterm-0.5.7

 

地点安装的设置路线为/usr/local/qterm-0.5.7,那些跟平时源码包./configure
prefix相似。

源码安装:

4.安装

1、安装注重包:

make && make install

     yum install cmake gcc gcc-c++ libaio libaio-devel automake autoconf
bison libtool ncurses-devel

那般就设置到位了。

                    libgcrypt-devel libev-devel libcurl-devel vim-common

成功以往,在目录/usr/local/qterm-0.5.7/bin/下得以找到施行文书qterm,做个软链接到面板上,那就顺理成章了,:-)

     libev-devel 包yum安装不上时,可手动RPM包安装

 

     rpm -ivh glibc-2.12-1.166.el6.x86_64.rpm

网站地图xml地图