编译问题的解决方法,关于问题ld

永利皇宫 ,目前写项目蒙受叁个题材,作者索要跟新友盟来适配iOS9.0+,全部就用cocoapods跟新了眨眼之间间友盟SDK,结果遇见了library
not found for -lXXX的难点,

关于难题ld:library not found for -lXXX

永利皇宫 1荒唐提示

ld:library not found for -lXXX
的主题材料有一点都不小希望是你的有个别库的总是援引不不荒谬,解决的方法正是在品种的target里,选中Link
Binary With Libraries 里的.a或framework 撤销再投入,就足以了
ld:warning:directory not found option 的标题恐怕是framework search paths
还只怕有Library Search Paths 里面并从未这些门路,删除就能够

接近之类的library not found for
-lXXX的主题素材,好找了一晚上到底找到难点的缘故在何地了在你的品类中找到Build
Settings —>Other Linker Flags选项

永利皇宫 2赶尽杀绝出错地点

网站地图xml地图